• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tachometer don't work...
#1
Hi guy's

On my 73', the tachometer don't work. I receive the car like that. It never worked.
I looked for the cable to repair it but I can't find anything.
Normally, there is a electrical cable that goes to the ignition coil and that works with the pulses, no ?
It's not like that on the 73' ?... Huh

[Image: SIGNATURE_3_paris.jpg]

  Reply
#2
Hi Jean-Pierre

Link to the wiring diagrams - hope this helps

https://www.7173mustangs.com/misc.php?page=diagrams

Regards Shane

Adelaide

73 Mach 1
  Reply
#3
Thank you, it's very nice.
I opened but, frankly, I'm not good enough in electricity.
If someone had a simpler solution...

[Image: SIGNATURE_3_paris.jpg]

  Reply
#4
The factory tach runs off the + side of the coil. Simply put, the wiring is:

12V from ignition switch goes to tach red wire, through tach, out on black wire, through the 'pink' resistor wire to the coil + terminal.

If the tach fails then the car will not run, so many of the tachs are unplugged and a jumper put in place of the tach so the car will run.


[Image: Tach-Wiring.jpg]

Bob

Tachs, Voltmeters, Headlight kits, Wiper delays and more at
[Image: smlogo.jpg]
Rocketman's Classic Cougar (and Mustang) Innovations, LLC
  Reply
#5
Humm, My tach does not work of 73 vert but car runs fine?? The wire is not jumped either I had entire dash out and put back it is plugged in. I even changed the tach and still did not work so I quite worrying about it and just drive the car.


When a man is in the woods and talks and no women are there is he still wrong??
Tongue
David
  Reply
#6
The tach can fail for a variety of reasons - the most talked about is transformer failure - this causes an open in the primary circuit so the car won't run. Probably the second most common issue is a dirty or worn movement, then dried out capacitors.

Bob

Tachs, Voltmeters, Headlight kits, Wiper delays and more at
[Image: smlogo.jpg]
Rocketman's Classic Cougar (and Mustang) Innovations, LLC
  Reply
#7
I'm going to do a wire search to see if it has not been jumped...

[Image: SIGNATURE_3_paris.jpg]

  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Windshield wipers won't go down and windshield washer won't work kevken1959 16 1,176 12-26-2017, 12:40 PM
Last Post: Stanglover
  Tachometer problem Kammertime 24 1,706 11-29-2017, 07:34 PM
Last Post: Kammertime
  Tachometer jackf 2 778 07-01-2017, 08:21 AM
Last Post: Stanglover
bulb Power windows stopped working, Gauge cluster lights don't work Neubonik 3 620 12-16-2016, 12:05 PM
Last Post: Carolina_Mountain_Mustangs
  tachometer bounces when battery is charging fonzogt25 5 993 09-27-2015, 06:39 PM
Last Post: fonzogt25
  Power windows don't work mpbsr 10 1,206 05-01-2015, 06:07 PM
Last Post: Carolina_Mountain_Mustangs
  Factory Tachometer Issues after restoring Instrument Panel! Cwithers 4 1,089 07-19-2014, 10:36 PM
Last Post: Cwithers
  Tachometer Lead wires turtle5353 3 871 05-20-2013, 08:10 PM
Last Post: midlife



Users browsing this thread: 1 Guest(s)