• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Reman Power Brake Booster Slack.
#1
Hello everybody,

Been doing some research on the forum about this issue I've been having with my brake pedal travel.

I noticed that I have about an inch maybe more of just pedal slack. (The brakes are not engaging whatsoever front/rear)

My system is completely stock from booster to calipers (mostly new-repro)


Last night after reading older threads on the subject, I adjusted the booster push rod as per the specs in the service manual. Unfortunately it didn't change anything, as I still have the same amount of slack in the pedal.

However,  I did notice that the rubber plunger (inside the booster when looking through the hole where the adjustable push rod is located) wasn't moving when my brother was moving the pedal back and forward in the "slack zone".

Interestingly, I have another booster that when I engage the rod on the pedal end (The side of the booster inside the car) it immediately moves the rubber plunger inside of it.

I'm confused right now and I would like to know if anyone else has experienced this issue before.

All input appreciated!
Thanks

Marco

"When the world is running down you make the best of what's still around."- Sting and The Police

[Image: IMG_5305.jpg]


  Reply
#2
How much did you lengthen the pushrod?

Did you replace anything else in the brake system?
  Reply
#3
(05-30-2018, 08:36 AM)Bentworker Wrote: How much did you lengthen the pushrod?

Did you replace anything else in the brake system?

0.990 with +/- 0.005" to ensure I wasn't compressing the master cylinder when I re-installed it.

The whole brake system has been replaced with stock spec parts. (No aftermarket)

Marco

"When the world is running down you make the best of what's still around."- Sting and The Police

[Image: IMG_5305.jpg]


  Reply
#4
If your drum brakes are not adjusted out to where they just give you a hint of drag you can have excess pedal travel.

As far as the pushrod goes, you should be good to go as long as it has a tiny bit of play before it engages with the master cylinder.
  Reply
#5
There appears to be something wrong with the booster. Maybe this thread will help you to understand how it's supposed to work
https://www.7173mustangs.com/thread-prop...#pid297715



“If you can't explain it simply, you don't understand it well enough.”
--Albert Einstein
  Reply
#6
(05-30-2018, 08:53 AM)Bentworker Wrote: If your drum brakes are not adjusted out to where they just give you a hint of drag you can have excess pedal travel.

As far as the pushrod goes, you should be good to go as long as it has a tiny bit of play before it engages with the master cylinder.

I forgot to mention that the rear drums were adjusted accordingly, just slight drag. I had to do that to get the parking brake to operate properly.


Should the pushrod move out when you barely touch the brake pedal? 

IMO , I get the feeling the other rod (eyelid) attached to the pedal assembly inside the car is not working properly/too short could this be possible?

In that its traveling before it contacts the rubber plunger inside the booster. > that would explain the slack and why there is no movement of the pushrod at the master cylinder end.

clueless.....

Marco

"When the world is running down you make the best of what's still around."- Sting and The Police

[Image: IMG_5305.jpg]


  Reply
#7
(05-30-2018, 09:58 AM)Don C Wrote: There appears to be something wrong with the booster. Maybe this thread will help you to understand how it's supposed to work
https://www.7173mustangs.com/thread-prop...#pid297715

Ok, did not see the rubber reaction disk unless it was wedged or fell inside the booster. That is interesting.
Would it still explain why there's a slack travel. Or its got to do with the valve rod?

Thanks for sharing that post!

Marco

"When the world is running down you make the best of what's still around."- Sting and The Police

[Image: IMG_5305.jpg]


  Reply
#8
It could be the valve rod, wrong one and too short. Unless you changed your pushrod, it has to be something wrong in the booster, wouldn't be the first new or remanufactured one that is messed up.



“If you can't explain it simply, you don't understand it well enough.”
--Albert Einstein
  Reply
#9
(05-30-2018, 11:16 AM)Don C Wrote: It could be the valve rod, wrong one and too short. Unless you changed your pushrod, it has to be something wrong in the booster, wouldn't be the first new or remanufactured one that is messed up.

My gut is telling me that too. Its not due to anything past the booster. Nope I did not touch the valve rod or the pushrod those came with the unit when purchased a while ago.

i will remove the booster and check it out thoroughly and post some pictures.

Thanks again Don for your opinion.

Marco

"When the world is running down you make the best of what's still around."- Sting and The Police

[Image: IMG_5305.jpg]


  Reply
#10
OK here is a recap of the booster issue. It turns out, that it was a combination of two points I had overlooked last week.

#1. The booster push-rod required adjustment and we made sure that the reaction rubber disk was present inside the "slot".

#2. I found excessive play in the connection of the brake pedal pin to the eyelid of the booster valve rod. I installed a plastic bushing in the eyelid. Made it even tighter by wrapping hockey tape around the outside of the bushing to ensure absolute zero play. See pic.

Brakes were then bled and we made last minute adjustments to the rear drums.

Took it out for a test-drive in our neighborhood: what a difference!

Even got the rebuilt transmission (FMX) to unlock ( the governor was stuck) by hard driving.

In all, it was a great weekend solving problems!

[Image: WP_20180530_21_16_50_Pro_5459.jpg]

Marco

"When the world is running down you make the best of what's still around."- Sting and The Police

[Image: IMG_5305.jpg]


  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Brake Distribution rambot 7 191 6 hours ago
Last Post: rambot
  Rear brake hose too short? Omie01 3 297 08-22-2018, 07:41 AM
Last Post: Hemikiller
  73 Master cylinder/brake booster combo LOUHABY 10 476 08-16-2018, 10:06 AM
Last Post: Carolina_Mountain_Mustangs
  Power Steering Gear Box jpaz 2 307 08-05-2018, 01:49 PM
Last Post: jpaz
runninpony brake pedal travel NOT A T5 4 351 07-24-2018, 05:05 AM
Last Post: NOT A T5
  Underdash brake pedal support turtle5353 17 631 07-19-2018, 05:18 PM
Last Post: c9zx
runninpony Brake Pedal Push Rod NOT A T5 5 419 07-11-2018, 05:47 PM
Last Post: Carolina_Mountain_Mustangs
runninpony Parking Brake Clip NOT A T5 6 381 07-11-2018, 05:18 AM
Last Post: NOT A T5



Users browsing this thread: 1 Guest(s)