• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pics needed please
#1
Hey guys, I'm still running into problems with trying to wire up the center gauges and speedo cluster. Turns out that the car never had the tach or center gauges so I'm still trying to work through that.

My question is does the voltage regulator need to be mounted to the back of the cluster and where? I know you have to snap it into place on the circuit board, but then what? There is a small copper square next to the snaps, but there is no way I can mount it onto that....it's almost like the snaps should be flip flopped. Does it need to mount onto here to make the connection?

This is where the pics would help so if you have some pics of the back of the speedo cluster w/tach and some close ups of the regulator mounting, that would be great!

Thanks for the help guys! I'm really at my wits end right now...Angry

"Life is what you make it......"
  Reply
#2
white73mach;19840 Wrote:Hey guys, I'm still running into problems with trying to wire up the center gauges and speedo cluster. Turns out that the car never had the tach or center gauges so I'm still trying to work through that.

My question is does the voltage regulator need to be mounted to the back of the cluster and where? I know you have to snap it into place on the circuit board, but then what? There is a small copper square next to the snaps, but there is no way I can mount it onto that....it's almost like the snaps should be flip flopped. Does it need to mount onto here to make the connection?

This is where the pics would help so if you have some pics of the back of the speedo cluster w/tach and some close ups of the regulator mounting, that would be great!

Thanks for the help guys! I'm really at my wits end right now...Angry
Hey White,
You secure the Vregulator with a screw and then fold the circuit ribbon over and snap into place on the Vreg. just like a 9v battery.
[Image: 16m6jpl.jpg]
[Image: 2zh1sg4.jpg]
Hope this helps! If not, then just let me know and I'll take my dash apart and get you the right pics Smile
DJ
  Reply
#3
That's perfect! I actually found out last night after I posted that the regulator I have IS backwards......cheap p.o.s.. I looked at some pics of regulators on the web and the mounting tab where the screw goes through it is on the top of the regulator, instead of the bottom, which is why I was having problems fitting it to the mounting hole.
Ordering another one now.

Thanks a bunch!

"Life is what you make it......"
  Reply
#4
Just thought I would add...that the regulator on a non tach dash is placed in a different area
[attachment=3005]

[attachment=3004]

[attachment=3006]

[Image: 1_14_01_12_10_54_29.png]

Ken

73 Convertible 302-4v-3spd yellow /white int

08 Bullitt 4.6-5 spd black/black int


All I ask is a chance to prove that money can't make me happy
  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Help Needed Turn Signal Switch Connector shooter_1967 6 642 07-22-2016, 07:19 PM
Last Post: shooter_1967
  Wiring advice needed: changing from 73 to 71 front end ScooterDog 6 727 03-30-2016, 07:00 PM
Last Post: midlife
  Pics of LED conversion Omie01 9 1,048 10-28-2015, 10:59 AM
Last Post: 72HCODE
  Wiring Experts needed bkdunha 7 1,048 12-26-2013, 10:45 AM
Last Post: MechEng
  wiring pros needed!! chargis1973 0 582 07-09-2012, 08:11 AM
Last Post: chargis1973



Users browsing this thread: 1 Guest(s)