• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No Power After Putting Engine Back In
#1
I just put a new engine and transmission in my 71 mach 1. I’m pretty sure I’ve hooked everything back up but I’m getting no power. I went to cfank it to get some oil pressure in it and got nothing. Lights won’t even come on. Battery reads 12.48 volts. Have the positive of the battery going to the side of the starter solenoid closest to the battery. The negative is going to the block. The wire from the starter is going to the other side of the solenoid, closest to the starter.
  Reply
#2
Have you tried jumping directly from the battery positive terminal to the "S" terminal on the solenoid to see if it will crank?

The lack of voltage to everything may be the fusible link, which is connected to the solenoid battery terminal (no gauges) or the terminal by the solenoid (with gauges).



“If you can't explain it simply, you don't understand it well enough.”
--Albert Einstein
  Reply
#3
u said the battery neg goes to the block.. that's fine but u NEED a neg to the body also. engine and trans sitting on rubber mounts don't do very well with grounding the car.
  Reply
#4
(07-29-2018, 07:20 AM)delawarebill Wrote: u said the battery neg goes to the block.. that's fine but u NEED a neg to the body also. engine and trans sitting on rubber mounts don't do very well with grounding the car.

If DelwareBillis correct, you could test quickly. Take a set of jumper cables, but only use the black. Put one black on battery NEG and the other black end to metal chassis somewhere so its well grounded. FWIW, when I redid my engine and bay, I bought 2 black neg cables (vs stock method of 1).  1 of my black NEg cables I ran down to block and bolted it on. The other runs from that bolt on engine, back up 18" to the fender ground point.  REALLY SOLID GROUNDING = no ghosts.
  Reply
#5
I added a grounding strap from the block to the frame. Turns over now! Now I have to get it to start haha. Thanks for the help everyone!
  Reply
#6
wow i got lucky on that answer... time to celebrate.. nap time.
  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Engine breakin oil question EvilPuppetMaster 10 184 7 hours ago
Last Post: EvilPuppetMaster
  Post your burbling bit (Engine) 1sostatic 6 261 Yesterday, 04:53 PM
Last Post: goodnigh
  Headers to fit '72 Mach 1 w/400 engine MeanMachine 7 201 03-22-2019, 04:25 PM
Last Post: donkost
  Power Steering Pully Diamether Carolina_Mountain_Mustangs 2 91 03-20-2019, 08:43 AM
Last Post: Carolina_Mountain_Mustangs
  Got my rebuilt Hurst 4 speed shifter back. Stanglover 24 668 03-19-2019, 12:05 PM
Last Post: Stanglover
  351C 4V - 72 Mach 1 Engine fan baz70 16 513 02-21-2019, 09:13 AM
Last Post: Stanglover
  Any tips for removing power steering pump ? baz70 13 323 02-18-2019, 10:26 PM
Last Post: Doc302
  Engine/dyno/speed programs mbrew2 3 227 02-03-2019, 09:28 AM
Last Post: c9zx



Users browsing this thread: 1 Guest(s)