• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
my bad
#1
Like a dufus I didn't take any pics when I tore my engine down. Didn't expect it to be down for a year. Now I can't remember how the power steering pump and the alt. brackets mount. If someone has any pic's of the brackests mounted
it will be a life saver.Huh
Jim

drive it like you stole it
  Reply
#2
Hey Jim. These might help a little. Mark

http://s841.photobucket.com/albums/zz340...0brackets/

My garage http://www.7173mustangs.com/forum-garage...rxt_uid=40

73 mach 1 351c 4v cc ported, torker2, 750 edelbrock,C6.
73 fastback 351c 2v,performer intake,600 edelbrock,fmx, 325 trac-lok.
  Reply
#3
machman_73;36223 Wrote:Hey Jim. These might help a little. Mark

http://s841.photobucket.com/albums/zz340...0brackets/

Mark thanks a load for the pics. P/S and Alt now on car. Owe you a drink in the lounge.
Thanks
Jim

drive it like you stole it
  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
Wrench low oil pressure or bad sensor or something else John J 3 484 07-13-2018, 07:29 AM
Last Post: Blue Mach 429 CJ
  bad timing issues, video Casperfast 20 1,530 04-16-2017, 11:46 AM
Last Post: Don C
  Bad odd compression test Video Casperfast 7 841 09-28-2016, 09:45 PM
Last Post: Casperfast
  Got my exhaust on and aligned(good and bad) sdstang 22 3,680 08-27-2015, 10:54 AM
Last Post: Pastorpat
  BAD NEWS.... ENGINE PROBLEMS bobmarlojill 20 2,576 07-16-2015, 10:02 PM
Last Post: InjectedMach
  No Wonder My Gas Mileage Was So Bad OLE PONY 2 1,078 06-06-2014, 08:49 PM
Last Post: OLE PONY
  tons of bad news for me auron73mach1 3 1,059 11-19-2012, 10:29 AM
Last Post: auron73mach1
  BAD DAY!!! Catastrophic engine failure!! Updated pics of the carnage. turtle5353 81 10,490 10-09-2012, 03:14 PM
Last Post: Joe Stang



Users browsing this thread: 1 Guest(s)