• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installing a new turn signal
#21
It sounds like you need more slack, so the two connectors aren't trying to pull themselves apart.  I'm still amazed by how far away the harness-side connector is.  I still think you need to get up in there, find the zip-tie(s) that's holding it back, and let it loose - the connector will fit better, and it won't dangle between your feet if you lay it over the column - something is preventing it from making it all the way over to where it needs to be.
Eric

[Image: mach1sig2.gif]
  Reply
#22
There is enough slack in the wires, no wires are pulled or stretched.
It feels like it doesn't fit but I can not see why when I compare to the old connector.

Did you put them together by hand or with the aid of some tool?
  Reply
#23
I put them back together by hand... but then again, mine were the original connectors (both sides) since I had to splice the new switch to the original connector.
Eric

[Image: mach1sig2.gif]
  Reply
#24
I would try some gentle persuasion, if you can get some needle nose pliers on it. The ears probably aren't going over the tabs.

You might take a look at the new connector and make sure there's not some flashing, from the mold, that's holding it back.

If it still won't go on and all of the connectors are making contact I would zip tie it to keep it from falling apart.


“If you can't explain it simply, you don't understand it well enough.”
--Albert Einstein
  Reply
#25
goodpost
Eric

[Image: mach1sig2.gif]
  Reply
#26
I was able to put mine together with one hand. My left arm is partially paralyzed, but I was able to get it together. There must be something preventing yours from going together. Hope you can figure it out.
run_horse Run Horse Run!
John 72 Q Code
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Installing Rack & Pinion Steering into a 1973 Mustang mustang7173 4 778 08-22-2016, 09:43 AM
Last Post: Jeff73Mach1
  pre-installing brake booster questions big_burgey 2 627 01-13-2015, 11:53 AM
Last Post: lduke12
  Replacing signal cam Vinnie 2 456 11-22-2014, 02:53 AM
Last Post: Vinnie
  Installing shocks Danno 5 930 07-29-2014, 05:45 AM
Last Post: Danno
  Power steering turn rate. BrandonDindorf 8 910 10-03-2013, 01:37 PM
Last Post: BrandonDindorf
  Help " installing steering pump" eddyw 1 590 08-09-2012, 12:50 PM
Last Post: will e



Users browsing this thread: 1 Guest(s)