• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
High idle
#1
I replaced the points and condensor with a petronix electronic ignition and now the car is running at a high idle. Anybody has any ideas to how I can adjust or what is going on?

Thanks
  Reply
#2
(11-28-2018, 09:34 PM)bigfootlarry Wrote: I replaced the points and condensor with a petronix electronic ignition and now the car is running at a high idle. Anybody has any ideas to how I can adjust or what is going on?

Thanks
make sure the choke cam is not holding the throttle open or that the air cleaner is not pressing on the choke linkage.

1. check the timing

2. disconnect the vacuum hose to the distributor then check the timing.

3. tell us what it is but if the engine is nearly stock, it should be ok anywhere from 6 to 10 degrees btdc.
  Reply
#3
When I changed from point to Pertronix on my 69 Mach 1, the timing changed (advanced) and I had to reset it. I would suspect that the same happened to you as well. i agree with Barnett468’s recommendations.
  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
runninpony Evans High Performance Waterless Coolant NOT A T5 10 469 07-20-2018, 06:43 PM
Last Post: computercarguy
  Most aggressive idle cam recommendation for stock CJ heads scgamecock 9 928 11-24-2017, 07:06 AM
Last Post: TommyK
  High torque starmotor is no more Fabrice 15 1,155 08-16-2017, 02:25 PM
Last Post: Fabrice
runninpony Installation of idle stop solenoid (kicker, compensator) Vanhook99 8 996 08-09-2017, 11:29 AM
Last Post: Don C
  Installed a high torque (PMGR) starter :-) Vinnie 11 1,559 10-06-2016, 01:59 PM
Last Post: tony-muscle
  Mechanical Help Please (fouled plugs/erratic idle/hard start) Paul4425 29 2,564 08-05-2016, 09:03 PM
Last Post: Paul4425
Wrench My new high-torque mini-starter is just awesome! Monterey 40 5,970 07-16-2016, 02:23 PM
Last Post: rafaelmd
  Edelbrock 4bbl idle issue on 1973 302 ustang73 7 995 05-16-2016, 07:31 AM
Last Post: jpaz



Users browsing this thread: 1 Guest(s)