• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Got another problem 351c
#1
engine turns over quick and starts idles rough quickly accelerates (standing still) pops a little ,,new plugs,cap points wires fuel pump,,no EGR valve  set air and fuel mix on carb still runs rough What would be a next step

THE WIND SHEILD COWBOY
  Reply
#2
Set the point gap (preferably by dwell angle) or replace if badly pitted. Set the timing.



“If you can't explain it simply, you don't understand it well enough.”
--Albert Einstein
  Reply
#3
That's Don ill try that in the next few days

THE WIND SHEILD COWBOY
  Reply
#4
(02-11-2019, 03:45 PM)batwrangler Wrote: engine turns over quick and starts idles rough quickly accelerates (standing still) pops a little ,,new plugs,cap points wires fuel pump,,no EGR valve  set air and fuel mix on carb still runs rough What would be a next step

Did it do this before you changed parts?
  Reply
#5
Yes it did

THE WIND SHEILD COWBOY
  Reply
#6
(02-11-2019, 03:45 PM)batwrangler Wrote: engine turns over quick and starts idles rough quickly accelerates (standing still) pops a little ,,new plugs,cap points wires fuel pump,,no EGR valve  set air and fuel mix on carb still runs rough What would be a next step

Have you done a compression test yet?


  Reply
#7
not yet fixing to do it in a couple days we just got 10" snow outside so I have to deal with that first Also the car has not been running for 10 years  I drain the old gas cleared the line today I think ill try to mess with the timing

THE WIND SHEILD COWBOY
  Reply
#8
(02-12-2019, 07:12 PM)batwrangler Wrote: not yet fixing to do it in a couple days we just got 10" snow outside so I have to deal with that first Also the car has not been running for 10 years  I drain the old gas cleared the line today I think ill try to mess with the timing

You ran the engine on 10 year old gas?
  Reply
#9
(02-13-2019, 08:21 PM)barnett468 Wrote:
(02-12-2019, 07:12 PM)batwrangler Wrote: not yet fixing to do it in a couple days we just got 10" snow outside so I have to deal with that first Also the car has not been running for 10 years  I drain the old gas cleared the line today I think ill try to mess with the timing

You ran the engine on 10 year old gas?

goodpost


  Reply
#10
supply the engine with some good gas, if that helps, you know the start of your issues. To me it sounds like a massive vacuum leak.

[Image: 1_01_07_15_8_53_18.png]

"I love my Hookers!" and "Get some Strange" probably have a different connotation to non automotive enthusiasts!
  Reply
Share Thread:  


Possibly Related Threads…
Thread Author Replies Views Last Post
  351c fan don blanchard 2 67 7 hours ago
Last Post: don blanchard
  351C 4V "quirks" Mystic Fish 11 1,419 7 hours ago
Last Post: Spike Morelli
  Correct 351C Power Steering Hoses? street rod mach 1 12 818 10 hours ago
Last Post: Don C
  351C 4V Exhaust system kcmash 14 2,861 08-09-2019, 04:57 PM
Last Post: goodnigh
  Power steering mounting 351c DeereFanatic 4 249 07-15-2019, 09:29 AM
Last Post: Carolina_Mountain_Mustangs
  73 Mach 1 351C w/AC vacuum line DeereFanatic 8 479 06-22-2019, 03:45 PM
Last Post: DeereFanatic
  Water Temp sender in water pump - 351C TheDude 34 1,238 06-11-2019, 08:06 PM
Last Post: TheDude
  Circle Track Overheating Issue 351C jdwest711 10 446 06-10-2019, 05:24 PM
Last Post: TommyK



Users browsing this thread: 1 Guest(s)