• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fuel sending unit
#1
I got a 20gal tank and sending unit kit from Laurel mountain mustang and my fuel gauge read full at 10gal of gas so when I put 20 gal in it said full until it got down to 10 gal then is started moving.   I then got the scott drake sending unit with the brass float from cj pony parts and it reads just the oposite on the gauge.  when I have 20 gal in the tank it reads full and I get it down to 10 gal it reads empty. anyone have any ideas on how to correct it or know of one that I can get that is correct.
  Reply
#2
This same issue was discussed a few days ago
https://www.7173mustangs.com/thread-float-material

You can find more by searching through forum.



“If you can't explain it simply, you don't understand it well enough.”
--Albert Einstein
  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
  No fuel can't start. mweeps 1 268 05-19-2018, 11:38 AM
Last Post: Don C
runninpony Fuel Vapor Canister NOT A T5 3 386 04-01-2018, 06:11 AM
Last Post: NOT A T5
  '73 fuel tank removal scottyrocks 8 790 03-20-2018, 08:46 AM
Last Post: Stanglover
  Fuel vapor separator asusnz 12 2,568 10-13-2017, 05:23 PM
Last Post: erikroy57
  Fuel line question for 72 Q-code eventhorizon 5 836 10-06-2017, 08:30 AM
Last Post: Stanglover
  Fuel vapor canister hose clamp sdstang 4 936 09-16-2017, 05:49 PM
Last Post: sdstang
  Has anyone replaced fuel lines w/o a lift eventhorizon 5 959 09-05-2017, 09:06 PM
Last Post: tony-muscle
  Fuel Tank Bondobax 6 831 08-11-2017, 06:17 PM
Last Post: NOT A T5



Users browsing this thread: 1 Guest(s)