• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine keeps running
#1
red logo 
After 5 years idle in the garage, the ole 302 kicked over today and sounds pretty darn good. The only problem is that I cannot turn the car off by the ignition switch. I try turning the switch off and taking out the key and it will not cut the power. We have to pull the coil to stop the engine. What's up?????

Brian Kulis
  Reply
#2
I'm guessing the starter solenoid is sticking
  Reply
#3
the ignition switch could be stuck internaly. see if you are getting 12v at the coil with the key off.

[Image: 2zem9nk.jpg]
Iyman
1972 Mustang convertible run_horse  
Visit the Mustang Car Club of New England Facebook Page

Visit the Mustang Car Club of New England Web Page

  Reply
#4
(11-22-2012, 08:10 PM)don29163 Wrote: I'm guessing the starter solenoid is sticking

+1. I would tap the solenoid lightly with a hammer and try it again.
  Reply
#5
After sitting that long it would probably do you good to go over all your connections (especially the grounds) and clean them. The solenoid may have to be replaced.

[Image: 2rr7aiv.png]

Just cruising along minding our own business when BAM!!! The LAWS show up.
  Reply
#6
I had the same problem. I ended up replacing the solenoid ($15 or so). My starter needed to be replaced too, but I thing that's a coincidence unless you noticed it never disengaged after the car started.
  Reply
#7
For what it's worth, I vote for the ignition switch. Pull it and see if there is continuity when in the off position.

[Image: 1673if.png]
50 F1
73 Mach 1
86 F150
96 F150
2014 F150
Always looking
  Reply
#8
I had this problem one morning, one tap to the solenoid with a rubber mallet fixed it. if you pull apart the steering column and actually look at the ignition switch and how it is set up, it would be pretty hard for it to stick in my opinion. safe bet if it has been sitting that long and you want it to be dependable, replace all the primary "electronics" in the car. solenoid, voltage regulator, starter, alternator, coil, ignition switch, and check the fuses and harnesses for any damage.

<img src="http://www.7173mustangs.com/gallery/1_12_09_14_10_32_45.png" />

- Nik
  Reply
#9
if the solenoid is stuck, wouldn't the starter be stuck on?

the only reason I mentioned the ignition switch, I had somthing break off in mine and it was doing the samething, it would start right up, and not turn off with the ignition, we had to pull the red wire off the coil to shut it off.

its an easy check. with the key in tthe OFF or in ACC mode you should have no voltage (0) at the red wire on the coil (between red and GRND) if you do have voltage, then you have an ignition issue, if not then this is not the issue.

[Image: 2zem9nk.jpg]
Iyman
1972 Mustang convertible run_horse  
Visit the Mustang Car Club of New England Facebook Page

Visit the Mustang Car Club of New England Web Page

  Reply
#10
imusa76;99373 Wrote:if the solenoid is stuck, wouldn't the starter be stuck on?

the only reason I mentioned the ignition switch, I had somthing break off in mine and it was doing the samething, it would start right up, and not turn off with the ignition, we had to pull the red wire off the coil to shut it off.

its an easy check. with the key in tthe OFF or in ACC mode you should have no voltage (0) at the red wire on the coil (between red and GRND) if you do have voltage, then you have an ignition issue, if not then this is not the issue.

Just goes to show anything is possible after 40 years. Confused

[Image: 2rr7aiv.png]

Just cruising along minding our own business when BAM!!! The LAWS show up.
  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Guage feed wiring harness question. Trying to repair after engine fire... 72sprint302 6 231 06-21-2018, 09:21 AM
Last Post: 72sprint302
  Engine fires only in start Ryunker 3 215 06-10-2018, 04:54 AM
Last Post: Ryunker
  Need Correct Engine Idle Speed 73StangCoupe 16 3,290 03-13-2018, 12:53 PM
Last Post: Don C
  Winter Engine Clean-up EBSTANG 7 676 04-06-2017, 03:47 PM
Last Post: Jeff73Mach1
  RE: my engine run video yesterday... Pastel Blue 4 594 02-20-2017, 01:05 AM
Last Post: Bentworker
  Engine Compartment Whistle JRL 4 567 01-30-2017, 08:47 AM
Last Post: Bill73Ragtop
  Rh engine bay wiring Justinc1973 4 676 01-28-2017, 08:36 AM
Last Post: Billyillyilly
  Toubleshooting Engine Timing / Distributor Installation bwilli 4 666 12-16-2016, 10:24 PM
Last Post: bwilli



Users browsing this thread: 1 Guest(s)