• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
a/c woes....
#1
So, a couple years ago, changed from Freon to R134.
Not a bad result, but in a 73 convert not great in S Florida.
Car went in to shop for lots of leaks and problems.
Came back with no a/c.
So, they did evac and recharge and still no air (its 95 in the day)
Told me the 2 after market cooling fans in front of rad are no good,so I went home to ponder.(and troubleshoot)
Found the fan relay wires were not good contact, cleaned them and fans now work.
Now,here's the problem,been like this a while,on first start from cool garage, I have cold air,pipe has condensation,water drips on ground from waste tube.
After the car warms up, fans still run,pipe has condensate,water drips from waste tube but no cold air in cabin.Blower fan works on all speeds.
I should point out the top lever on the a/c controller has to be just to right of min a/c.to get cold air first thing.
Any advice ,please?

UPDATE:
Just did a 9 mile run,on I 95,at 65+mph. Had nice cold air all the way.
Stopped for maybe 5 minutes, started up,drove home. Got warm air for first 4 miles, then not real cold last 5 miles.
Stopped to check a/c hoses at 2 miles-cold with condensate.
At home,finally, cold pipe, poor a/c but water dripping out from overflow.
I DID manually push the door closed,as the cable was leaving 1/4 inch of switch rod out.(thats under the glove box.)
Unit is definitely working, but I have to have the top lever about 1 1/2 inches to the right to get any air.
Any clues here?
Thanks,
Adrian
NEW UPDATE: a couple of hours later......quite a lot of water from a/c under the car,now.
Is it possible its FREEZING up and now melting?
Adrian
  Reply
#2
What is air temp coming from vent on low? the more humidity you have (florida) the more it will sweat. Can you manually switch it to max cool under dash to check the unit? that would tell you if it is control cable or vent door.
  Reply
#3
Is the hot water control valve... on the heater hose that goes to the water pump ?
  Reply
#4
don29163;82324 Wrote:Is the hot water control valve... on the heater hose that goes to the water pump ?

Old one was stuck open, I recently put in a new manual one,made a lot of difference!

caspianwendell;82318 Wrote:What is air temp coming from vent on low? the more humidity you have (florida) the more it will sweat. Can you manually switch it to max cool under dash to check the unit? that would tell you if it is control cable or vent door.

In max cool, no air, in recirc, plus 1/2 inch to right, cold on start up....then poor after a few miles.
Lower hot/cold cable works, upper one seems to work but nothing visible controlled!
  Reply
#5
Low charge or low air flow will cause evaporator freeze up.

As has been asked, is heater control valve in place and stopping hot water to heater core?
What are the system low and high pressures at what outside air temp?
What is the a/c inlet air temp (cabin) temp?
What is the outlet air temp when it does cool?

Sounds like you are fighting multiple issues. Get your min/max cable issue resolved, then the heater control. That might solve your issues.
  Reply
Share Thread:  




Users browsing this thread: 1 Guest(s)