• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
20 amp fuse blowing
#1
Just had the car out for a drive and noticed my console clock stopped working. Checked and fuse #7 (20amp), according to the owners manual, was blown so I replaced it and the new one popped instantly. Started looking and the horn is also on that circuit and not working. I know it is a constant power circuit so I unplugged the clock and horns up front, tried again and blew another fuse. Any ideas on where to look and what about bypassing the fuse? Gotta love electrical issues! Thanks.

Marty
  Reply
#2
Marty, Go to the top of this page select data, then 73 wiring diagram. There are 2 20 Amp fuses listed next to a drawing of the fuse block. The Schematic shows F4 powers the clock, F3 powers the horns and lighter, F7 powers blower motor and AC clutch. What else, if anything doesn't work?

Chuck
  Reply
#3
c9zx;17694 Wrote:Marty, Go to the top of this page select data, then 73 wiring diagram. There are 2 20 Amp fuses listed next to a drawing of the fuse block. The Schematic shows F4 powers the clock, F3 powers the horns and lighter, F7 powers blower motor and AC clutch. What else, if anything doesn't work?

Chuck

Thanks Chuck, according to that fuse box in the wiring guide, it's fuse #1 that blowing (different fuse layout then I have). The cig lighter and horn aren't working and the console clock. I've checked about everything else and all seems well to include blower motor. Don't have AC. The only electrical work I've done in the last couple of weeks was replace the original bootcap cover for one of the wires on the pos side of my coil for an eyelet one to use with the nut that came with my accel coil. The bootcap kept slipping causing the car to stall.
  Reply
#4
pull the lighter and see if the short is still there
  Reply
#5
Marty, Does the car have the convenience group (seat back release relays, under hood light, etc)? If it is F1 as shown on the schematic, find F1 and wire 297 and 296. I've traced the path from end to end. Nothing I see explains why the clock and horns don't work. They did work before, right.Smile Does the radio, fuel gauge, flashers, and seat back relays (if you have them) work?

Chuck
  Reply
#6
Figured it out at last, I finally turned on the headlights in the garage and found that the front right side marker light wasn't on. Pulled the bulb, cleaned it and it came back on. I'm guessing that it was shorting in the socket and blowing the fuse. Horn works now, but the clock got fried. So now I'm looking for a clock!
c9zx;17705 Wrote:Marty, Does the car have the convenience group (seat back release relays, under hood light, etc)? If it is F1 as shown on the schematic, find F1 and wire 297 and 296. I've traced the path from end to end. Nothing I see explains why the clock and horns don't work. They did work before, right.Smile Does the radio, fuel gauge, flashers, and seat back relays (if you have them) work?

Chuck

Thanks for the help Chuck, I owe you a beer or two.
  Reply
#7
I'm glad you found the problem and it was an easy fix. The light you mentioned is powered by F4. The horns are powered by F3, according to the schematic. Perhaps Ford did a wiring change that doesn't show up on the version posted. Lord knows they made LOTS of changes in 1972, it's a long story. Sorry I wasn't able to help much, but I'll still accept the beer.

Chuck
  Reply
#8
I do not think the bulb was causing a 20 amp fuse to blow.
  Reply
#9
If it was a direct short to chassis ground then the 20A fuse could have easily blown.

Steve



[Image: 25yvyp3.jpg]
  Reply
#10
sm3570;17845 Wrote:If it was a direct short to chassis ground then the 20A fuse could have easily blown.

re-read my post, steve.
  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Blowing Fuse on Accessory / Ignition Circuit Butch65 17 961 07-10-2018, 10:30 AM
Last Post: Don C
  73 fuse box questions Vinnie 31 1,088 05-30-2018, 01:36 PM
Last Post: Vinnie
  Where Can I Get Replacement Fuse Block? icejawa 19 1,889 06-21-2017, 05:12 PM
Last Post: midlife
  Need help where to install aftermarket fuse box Billpetsch 5 825 09-05-2016, 07:29 AM
Last Post: mach1000
  blue wire with white stripe by fuse box fonzogt25 9 1,620 10-28-2015, 06:42 PM
Last Post: fonzogt25
  Fuse Box in my 73 Mach 1 Salhi_amer 11 2,359 08-14-2015, 07:34 PM
Last Post: midlife
  No Power to #3 fuse, instrument cluster ponypastor 5 2,975 04-07-2015, 01:55 AM
Last Post: thomas1984
  Energy lost totally, fuse panel was loose Jarturin 1 745 12-20-2014, 09:25 PM
Last Post: rvrtrash



Users browsing this thread: 1 Guest(s)