• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dash lights inop.
#1
Just reinstalled the dash.(idiot light type), and the backlights do not work, also my oil pressure and alt lights don't test when key turned, brake and temp lights work ok.
I replaced plastic dash unit and replaced the bulbs a while ago while the unit was out along with swapping the ribbon wiring over to the new unit. I am probably going to have to bite the bullet and remove this cluster again and see what is going on. I read somewhere there is a way to test the lights while in the unit with a 9 v battery. Either I have bad bulbs, or maybe damaged something shoehorning the unit back into place. As I remember, they were lit before I removed the unit. The gas gage and a light by the odometer work, as does the rheostat on the headlight switch, also the switch illumination lights work so that 4 amp fuse is good.
Any thoughts on that 9 v battery test? Undecided
Just went back out and checked in the dark, the lights, (most of them) come on but very very dim, and the gas gage doesn't light at all. Possible CVR?
  Reply
#2
The CVR provides a constant voltage to the gauges, only. The dash lights are affected by a bad ground, bad connection, or bad rheostat. The plastic domes over each bulb can also become clouded over time. Quite a few members of this forum have switched to LEDs, which gives you several color options (after removing the plastic domes).



“If you can't explain it simply, you don't understand it well enough.”
--Albert Einstein
  Reply
#3
Sounds like you've already covered a lot of the possibilities.

The good first check is to see what kind of voltage level you're getting out of the headlight switch itself heading over to the gauge lights (this can be done easily with the plastic piece removed from the dash but gets a little harder with it installed)

If you've got good voltage (anything at about 10.5 and up with the switch at "full") the next step unfortunately is to pull the cluster. More than likely you've got dirty connections on both the flex circuit and the little plastic cups that the bulbs set into. A good way to clean the flex circuit without damaging it is to use a pencil eraser, it'll take some elbow grease, but it'll polish the contacts without wearing them down too much or scratching them up like sandpaper can.

You can certainly test the flex circuit with a 9volt battery, it'll work just fine. When I was working with mine on the bench I used a 12V power cube. Just be careful with it, and don't leave it connected for too long, those filament bulbs will pull a lot of current if you let them and get quite hot.

I would pull each bulb out one at a time and use a 9v to put voltage across the holder. Doesn't do you any good to test the bulb if it's corroded contacts in the holder itself causing you issues.

Just go step by step and you'll get it figured out. I just swapped to LEDs in my dash, it's a nice change, picked up a little brightness but the dash is still much too dim for my tastes. Also, with most LED kits, you're going to loose the ability to dim your dash lights at all, so keep that in mind if you decide to go for the swap

2013 Ford Focus SE Flex Fuel 5spd - Daily Driver
  Reply
Share Thread:  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Dash end panel oddity Pegleg 2 202 07-03-2018, 10:55 AM
Last Post: donkost
Wrench Center Dash Gauges and Radio Bezel refurb OzCoupe72 16 740 07-01-2018, 11:10 AM
Last Post: naa10104
  Cleaning Paint off of Dash Bezels kcmash 4 289 06-13-2018, 06:38 AM
Last Post: Pegleg
runninpony Dash Speaker Grille/Bracket NOT A T5 8 510 05-04-2018, 06:19 AM
Last Post: NOT A T5
runninpony DASH PAINT NOT A T5 4 436 04-25-2018, 10:51 AM
Last Post: Stanglover
  Mach 1 Grill Running lights jowens1126 14 1,364 03-11-2018, 07:49 PM
Last Post: jowens1126
  Got new tail lights in!! Omie01 3 389 01-24-2018, 09:38 AM
Last Post: Fabrice
  Dash center map light Rmelnik 4 710 12-08-2017, 10:16 PM
Last Post: Rozz



Users browsing this thread: 1 Guest(s)